EVGA GeForce GTX660 2GB Artifacting Investigation & Fix Attempt (Only With Drivers Installed)

  • 🎬 Video
  • ℹ️ Description
preview_player
UCmP8HEyzLdYfHXD5C7r908Q

In this video I attempt to fix a EVGA GeForce GTX660 2GB Superclocked graphics card sent to me by a friend. He actually sent me this a while back as it started to have artifacting problems.
Artifacts can greatly vary in style, but generally they are flashing or intermittent colored blocks and random graphical glitches that appear on screen.
In this case the GPU works fine until a driver is installed and running for it, which is a strange problem but understandable as the graphics card switches into different modes when a driver is installed vs. when no driver is present (2D vs. 3D modes for example).

Here I attempt to fix this problem through a few different methods including installation of different driver versions and reflashing the BIOS software on the actual graphics card with a replacement from the TechPowerUp VGA Bios collection using the nVidia NVFLASH utility.

Will any of my troubleshooting or fix attempts work - Or did this graphics card just give up completely?.. Let's find out....





Recorded Using A Samsung Galaxy S5 SM-G900F.

💬 Comments
Author

Well, thank you at least I know what will eventually become of mine if I don't fix the problem sooner than later. This may have been May 2018, but my card most recently started behaving strangely in games, one problem I notice with this card is its most likely not the core temperature itself, but I can't believe with that blower they stuck on the front of it that it would attract a lot of dust on top of the card. The card runs great in low power mid power and high power, it craps out at overclocking power and makes my system wait for commands. I believe this could have been avoided if they didn't use a stock Nvidia GTX 660 blower on a SC card what a bunch of idiots. Super clock is the same as overclock but it sales better. The problem is the Bios is exposed on the back of the card to rotating air flow by CPU fan and power fan if you use a stock cooler, and equalizing fan I used to have went out, dust can collect on the top of the graphics card and be moved around by air flow creating static electrify that is strong enough to corrupt data on the Bios chip. Also I would question the choose of memory they are using for the cards dedicated memory failed for system memory 10 times in a row. So they recycled it into Graphics cards where the memory is not as crucial, but still prone to failure. DDR5 a major failure and delays makes me want to cry. There was a program I can't remember where live program I found on YouTube that the guy sent in the card to be fixed because the first sign is screen freezing and CPU spike to 100% randomly, and when he re flashed the bios it worked and the card was saved, the only major problem is if not fixed the corruption can move down the power levels and than it wouldn't matter what you do to the bios the chips are already corrupted. I am just afraid to do it because if you do it wrong you can loose your graphics card for good. Edit but if you keep your graphics settings on high in most games you can minimize the damage until you get a newer upgraded card. Keep the settings away from Ultra to avoid the spikes that damage the card and unhealthy for the CPU.

Author — Sid1701D9 The Sims channel

Author

I had a 550ti where It puked rainbow all over my login screen and shit itself shortly after

Author — Taika

Author

I remember my 1050ti was artifacting, but it got fixed when I changed my motherboard since one of the pins or something got damaged.

Author — Chunky Clumpy

Author

Thinkin to try an attempt on a 770 reference, but there are horizontal green lines that make me think of a permanent damage

Author — Luca Rossi

Author

My Asus NVidia GeForce GTX660 TI had the exact problem couple of nights ago after 8 years of installing it. At the windows 7 login screen, screen artifact of pink pixels like doughnut sprinkles shortly followed by a blank screen with a blend of blue and white. I'm convinced it's worn itself to buggery after carrying out many tests.

Author — GhostBehindASolidShock

Author

that’s what happens to mine expect not nearly as bad of flashing and crazy slow in games or crashes when loading in

Author — Ethan Colbert

Author

Oh dear, remember this early 2000s when everybody was using a testbench old computer to test parts and it was having Windows Xp? Well, now in 2019, these Windows Xp systems have been replaced with Windows 7 old ones

Author — Mitsos Tech Tips

Author

In my emulation pc I have I think some kind of old reason r270 or something like that it does artifacts very similar to this car but it only occurs during the android off process when I got from bios to loading Into windows but if it makes it past the windows does loading screen without an artifact appearing I can run heavy loads even run ark survival evolved on it on medium settings for hours with no artifacts so it has me thinking theres a problem with either the vram having an issue during the hand off or the bios

Author — StoneyGameCentral

Author

My problem ended up being that the thermal paste bridged the transistors around the dye. My card stopped showing a picture and literally crashed with artifacts 3 seconds after starting a game. It bugged me for months but when I cleaned the old thermal paste i worked as new at least for now.

Author — Filip Andersson

Author

DUDE OUR GRAPHICS CARD IS SAME, but the fan isn't working somehow

Author — A Noob

Author

I’m having troubles with textures on characters in be chat glitching out and it does it on my car as well do u have a discord I could ask if u could help me?

Author — Megumin Nightcore

Author

I'm having this problem too on a 660TI 4 GB. Mine looks like checker squares of TV static, similar to his but without the colors. Somehow I've gotten it down to only at the startup screen most of the time. Still no idea how to fix this.

Author — Chase H

Author

My son has the same problem but on rx 580 armor msi can you help us solve the problem?

Author — Michał Stepień

Author

i have the same problem. when drivers a installed lines appear on the scree. please help

Author — Willie Henry

Author

I have a simillar problem with my Msi Radeon Hd 5770 1gb, and it just has a blank screen after windows 7/10 logo with drivers on. Without drivers it boots ok, this card has not hours, I mean, it is never used, I heard about a Bios Flash update and people saying that it is making this card to work again

Author — Mitsos Tech Tips

Author

just purchased a XFX 560 today i turn it on and it looks like this.. It sucks man.. im trying to trouble shoot this but i think its the card.. lemme continue to watch

Author — PCgamerware

Author

I rly need help I just ran bios to try to fix something changed one setting and reload to a pixelated ranbow I really need help

Author — LostLove

Author

My gpu got artifacts but the screen freeze when it happens and my only choice is turn off the PC

Author — Sara Dahlke

Author

i Think you have to: make Your GPU less overclocked.. if you add too much MhZ for it it will puke colors

Author — CarlRayanitch

Author

I’m having the same issue with my gtx 770

Author — YeaminPlayz